Six Apart patches Movable Type

In a message posted on its corporate blog earlier this morning, blogging software maker Six Apart essentially admitted that security holes in its Movable Type product(s) are to be blamed for the recent, prominent hacking and defacement of the PBS.org website, which occurred at the end of last month.

This reminds me of a post on Daring Fireball:

I don’t religiously keep my installation of Movable Type up to date, and I know many other MT users don’t either, and yet our sites don’t get hacked. I’m not arguing that Movable Type is perfect. Clearly, it is not. No software is. I’m just saying the situation with WordPress is different, and clearly more dangerous, than it is on other platforms.

“Clearly more dangerous?” Obviously.