Starting to get a bit sick and tired of the FUD people are spreading about WordPress. Today’s highlight (paraphrased): “WordPress is super insecure and doesn’t even offer automatic updates”. Except a) it’s more secure than other CMSes—especially less popular ones—and b) WP has had auto-updating built in since 3.7.